Error Adding KDE:Qt56 Repository for Leap 42.1

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error Adding KDE:Qt56 Repository for Leap 42.1

Nderitu
KDE:Qt56 is listed as an incompatible repository despite it being a legitimate repository for Leap 42.1. Trying to add it results in an error where all repositories for your current build become unavailable and trying to remove the repository is next to impossible at that stage.

KDE:Qt56 repository is required when adding KDE:Frameworks5:LTS to your build which one of a few to provide packages for KDE Framework5 for Leap 42.1.

If anyone can fix this issues, I will be very grateful.

Thank you.
Reply | Threaded
Open this post in threaded view
|

Re: Error Adding KDE:Qt56 Repository for Leap 42.1

Nderitu
Reply | Threaded
Open this post in threaded view
|

Re: Error Adding KDE:Qt56 Repository for Leap 42.1

Nderitu
I am unable to add this project's repository for openSUSE Leap 42.1. I have tried the following to no avail.

When I click on "Add Repository" in my appliance and try searching for "KDE:Qt", it yeilds 3 repositories: KDE:Qt58 Leap_42.1, KDE:Qt55 Leap_42.1 and KDE:Qt57 Leap_42.1 only.

I then tried searching for "libqt5-creator" and it yeilded 6 repositories:debug leap 42.1, KDE:Qt58 Leap_42.1, KDE:Qt55 Leap_42.1, openSUSE Leap 42.1 OSS, KDE:Qt57 Leap_42.1, and openSUSE Leap 42.1 Updates only.

I try again this time, I click on, "Import new repository". Using the project name KDE:Qt56 or KDE:Qt56 Leap_42.1 to add the repository fails with no error message. Using "Add a repository via URL", http://download.opensuse.org/repositories/KDE:/Qt56/openSUSE_Leap_42.1/ also fails.

By default, "Exclude incompatible repositories" is enabled by default. I disable it and try to look for the repository again using "KDE:Qt" and this time the repository is found but adding it with the above option disabled results in an error where the appliance/build is unable to retrieve the "Software Information". At that state one cannot proceed with his/her build as a result of the error.
Reply | Threaded
Open this post in threaded view
|

Re: Error Adding KDE:Qt56 Repository for Leap 42.1

Luna OS
I think it is not compatible. So it probably won't let you add it.