PHP repository?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

PHP repository?

asonnenberg
Our product runs on an SLES appliance. For years I have built SLES 9, SLES10, and SLES 11 appliances using VMware Studio. I have had no luck using it to build a SLES12 appliance.

Due to that, I am investigating using SUSE Studio to build 'our appliance' on SLES12 SP1. On SLES 11 the appliance uses packages php53, but I cannot find php in SUSE Studio, I only see php5-devel. Selecting that give an error:

Nothing provides package php5 = 5.5.14 which is needed by package php5-devel
Remove php5-devel

Any ideas how to access the repository for PHP in SUSE Studio?

Thanks
Alan
Reply | Threaded
Open this post in threaded view
|

Re: PHP repository?

DocB
asonnenberg wrote
Due to that, I am investigating using SUSE Studio to build 'our appliance' on SLES12 SP1. On SLES 11 the appliance uses packages php53, but I cannot find php in SUSE Studio, I only see php5-devel. Selecting that give an error:

Nothing provides package php5 = 5.5.14 which is needed by package php5-devel
Remove php5-devel

Any ideas how to access the repository for PHP in SUSE Studio?
If you look at OBS, you find devel:languages:php, which provides PHP5 and 7.
But I saw that it does not build for SLE12 SP1 - conflict for provider of libfbclient2-devel, (provider libfbclient-devel obsoletes installed firebird-devel). You should get in touch with the maintainer to resolve this, then you can include the repository in your build
Reply | Threaded
Open this post in threaded view
|

Re: PHP repository?

Roger
While the OBS build currently reports issues it can still be found as a software source within susestudio

On the software page

    Select Add repositories
    Search for php5
    Select devel:languages:php (SLE_12_SP1)