RPM output: error: Failed dependencies: /bin/sh is needed by...

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

RPM output: error: Failed dependencies: /bin/sh is needed by...

Lietukas
Hi, What may be wrong with RPM package and how to fix this if I can not install it in susestudio and this error: The following errors occured while building your image: Expected 1662 packages, installed 0. RPM output: error: Failed dependencies: /bin/sh is needed by Lietukas-workspace-20141215-1.1.noarch Following packages were not installed: err err2
Reply | Threaded
Open this post in threaded view
|

Re: RPM output: error: Failed dependencies: /bin/sh is needed by...

DocB
Try to install the package 'dash'
Reply | Threaded
Open this post in threaded view
|

Re: RPM output: error: Failed dependencies: /bin/sh is needed by...

Lietukas
In reply to this post by Lietukas
Becides, I attached images, you can see it http://suse-studio-users.1598176.n2.nabble.com/RPM-output-error-Failed-dependencies-bin-sh-is-needed-by-td7578886.html

2014.12.15 18:02, Lietukas rašė:
Hi, What may be wrong with RPM package and how to fix this if I can not install it in susestudio and this error: The following errors occured while building your image: Expected 1662 packages, installed 0. RPM output: error: Failed dependencies: /bin/sh is needed by Lietukas-workspace-20141215-1.1.noarch Following packages were not installed: err err2

View this message in context: RPM output: error: Failed dependencies: /bin/sh is needed by...
Sent from the SUSE Studio Users mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: RPM output: error: Failed dependencies: /bin/sh is needed by...

Lietukas
In reply to this post by DocB
Thanks for suggestion, but installing the package 'dash' does NOT helped...


2014.12.15 18:06, DocB rašė:
> Try to install the package 'dash'
>
>
>
> --
> View this message in context: http://suse-studio-users.1598176.n2.nabble.com/RPM-output-error-Failed-dependencies-bin-sh-is-needed-by-tp7578886p7578888.html
> Sent from the SUSE Studio Users mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: RPM output: error: Failed dependencies: /bin/sh is needed by...

Lietukas
In reply to this post by DocB
I rebuilded RPM package and removed %pretrans. Now it works.
Reply | Threaded
Open this post in threaded view
|

Re: RPM output: error: Failed dependencies: /bin/sh is needed by...

jpvoodoo
In reply to this post by Lietukas
I had a similar problem with a vmware vm that was installed via pre-load ISO. I tried 2 separate installs in a virtual machine. All the preload ISO does is decompress the same raw disk image you use for your USB stick.

The first time I got to the login with no gui and rebooted it because I got tired of waiting and it booted to gui.

The second time I got to a login prompt and it booted into gui via init 3, init 5.

Both times I noticed that I couldn't move any windows. I tried to run kwin --replace and realized kwin was not even installed. I installed that and I could drag the windows.

I've been having problems doing builds because the "BUILD" button was grayed out and disabled. I did finally get one to run with just the base config with kde, but i still couldn't drag the windows.

Other times I tried it, by catching a green button at just the right moment, the build failed with complaints about alot of missing rpms

I think the build is not finding th correct rpms. I think they just set up 13.2 about 3 days ago and are having problems. We may have to give them some time.

I tested a 13.1 build and the build button was not disabled, so it seems to just be with 13.2.